Excelde EĞER Fonksiyonu Kullanımı

Excel'in gelişmiş fonksiyon kütüphanesinden EĞER(IF) fonksiyonunun kullanımını kısaca bu yazımızda işleyeceğiz. Kullanım Formatı şöyledir;

=EĞER("Şartımız"; "Şarta Uyan Durum"; Şarta Uymayan Durum)

Gördüğünüz gibi formül 3 kısımdan oluşmaktadır. İlk kısımda şartımızı yazıyoruz, ikinci kısımda bu şarta uyan durumda ne yapılacağını, üçüncü kısımda da şart gerçekleşmezse ne yapılacağını yazıyoruz. Kısımlar arasında Noktalı Virgül (;) konulduğuna dikkat ediniz.

İngilizce Excel'de IF, Türkçe Excel'de EĞER diye geçmektedir, geri kalan kısımların kullanımı aynıdır.

Aşağıdaki tabloda girilen notlar ve ortalama yer almaktadır. Ortalama değeri 50'den küçükse, "Kaldı", Büyükse "Geçti" yazılmasını sağlıyoruz. Türkçe Excel kullanıyorsanız IF yerine EĞER yazınız.






=IF(D2>=50;"Geçti";"Kaldı")
=EĞER(D2>=50;"Geçti";"Kaldı")


Excel'de iç içe IF kullanımı da mümkündür. Böylece birden fazla durumu olan koşulları yazabilirsiniz. Örneğin;

 0 - 49     Arası ZAYIF
50 -69    Arası ORTA
70 - 84   Arası İYİ
85 - 100 Arası PEKİYİ






Yukarıdaki tabloda da göreceğiniz formülü aşağıdaki şekilde yazabilirsiniz.


=IF(D2<50;"Zayıf";IF(D2<70;"Orta";IF(D2<85;"İyi";"Pekiyi")))
=EĞER(D2<50;"Zayıf";EĞER(D2<70;"Orta";EĞER(D2<85;"İyi";"Pekiyi")))


Bu örnekleri daha da genişletebiliriz, örneğin Vücut Kitle İndeksini de siz hesaplayabilirsiniz. Bir sütuna Boy, bir sütuna Kilo, bir sütüna da VKI (Vücut Kitle İndeksi) değerini yazınız.  

http://tr.wikipedia.org/wiki/V%C3%BCcut_kitle_indeksi

Çözüm:
=EĞER(D5<20;"Zayıf";
EĞER(D5<25;"Normal";
EĞER(D5<30;"Hafif Şişman";
EĞER(D5<35;"Şişman"; 
EĞER(D5<45;"Sağlık açısından önemli";
EĞER(D5<50;"Aşırı şişman";"Morbid"))))))

EXCEL DOSYASINI İNDİR

İyi çalışmalar,
Oğuzhan TAŞ
Ocak, 2015



Bookmark and Share
Dil Değiştir(Change Language)